My argument for why the future will be *multi-chain*, but it will not be *cross-chain*: there are fundamental limits to the security of bridges that hop across multiple "zones of sovereignty". | Vitalik Buterin old.reddit.com/r/ethereumโ€ฆ
Stuck on multi-hop eBGP adjacency, probably missing something simple

Ok here is my topology and configurations. I'm kinda lost here. The error I am getting is.....

 BGP state = Idle (No route to multi-hop neighbor)

https://preview.redd.it/3i9q4yxhavc81.jpg?width=1832&format=pjpg&auto=webp&s=d6e5333bcb976596f7c789203e0c89a10cc9a0a5

ROUTER 1

Building configuration...
!! IOS XR Configuration 6.1.3
!! Last configuration change at Thu Jan 20 15:51:35 2022 by pdoty
!
domain lookup disable
interface Loopback0
 ipv4 address 2.2.2.2 255.255.255.0
!
interface MgmtEth0/0/CPU0/0
 shutdown
!
interface GigabitEthernet0/0/0/0
 shutdown
!
interface GigabitEthernet0/0/0/1
 ipv4 address 172.16.200.2 255.255.0.0
!
interface GigabitEthernet0/0/0/2
 shutdown
!
router ospf 1
 router-id 2.2.2.3
 area 0
  interface GigabitEthernet0/0/0/1
   neighbor 172.16.200.1
  !
 !
!
router bgp 100
 address-family ipv4 unicast
 !
 neighbor 1.1.1.1
  remote-as 200
  ebgp-multihop 255
  update-source Loopback0
  ignore-connected-check
  address-family ipv4 unicast
  !
 !
!
end

ROUTER 2

interface Loopback0
 ip address 5.5.5.5 255.255.255.0
!
interface FastEthernet0/0
 ip address 192.168.100.1 255.255.255.0
 ip ospf 1 area 0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 172.16.200.1 255.255.0.0
 ip ospf 1 area 0
 duplex auto
 speed auto
!
interface FastEthernet1/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
router ospf 1
 router-id 3.3.3.3
 log-adjacency-changes
!
router bgp 1
 no synchronization
 bgp log-neighbor-changes
 network 1.1.1.1
 network 2.2.2.2
 neighbor 1.1.1.1 remote-as 100
 neighbor 1.1.1.1 update-source Loopback0
 neighbor 1.1.1.1 next-hop-self
 neighbor 2.2.2.2 remote-as 200
 neighbor 2.2.2.2 update-source Loopback0
 neighbor 2.2.2.2 next-hop-self
 no auto-summary

ROUTER 3

cdp advertise v1
interface Loopback0
 ipv4 address 1.1.1.1 255.255.255.0
!
interface MgmtEth0/0/CPU0/0
 shutdown
!
interface GigabitEthernet0/0/0/0
 cdp
!
interface GigabitEthernet0/0/0/0.10
 ipv4 address 192.168.10.2 255.255.255.0
 encapsulation dot1q 10
!
interface GigabitEthernet0/0/0/0.20
 ipv4 address 192.168.20.2 255.255.255.0
 encapsulation dot1q
... keep reading on reddit โžก

The Hillsboro Hops are preparing to implement a $40M-plus stadium expansion โ€” most of it privately funded โ€” that will transform the ballpark into a multi-use venue and help cement the city's status as a key regional economic player.

https://www.bizjournals.com/portland/news/2022/01/19/hops-bids.html?ana=TRUEANTHEMTWT_PO&csrc=6398&taid=61e851aef89f730001e56f2b&utm_campaign=trueAnthem%3A%20Trending%20Content&utm_medium=trueAnthem&utm_source=twitter&s=09

DBacks High-A affiliate, the Hillsboro Hops, are preparing to implement a $40M-plus stadium expansion โ€” most of it privately funded โ€” that will transform the ballpark into a multi-use venue. /r/HillsboroHops/commentsโ€ฆ
Root + Branch - Like Flies on Sherbert. An 8% Multi-oat/Wheat Sour DIPA brewed with Citra, Galaxy and Motueka hops and milk sugar; refermented on cara cara orange puree.
Bad Motherfucker Blues - The multi-genre playlist that consists of fight music, mostly Hip-Hop/Rapcore/Alternative/Nu-Metal. open.spotify.com/playlistโ€ฆ
IVPN for iOS v2.5.0 is out with WireGuard Multi-hop, native iOS Kill switch support

More details: https://www.ivpn.net/blog/kill-switch-and-wireguard-multi-hop-added-to-ivpn-for-ios/

Changelog:

[NEW] Multi-Hop for WireGuard protocol

[NEW] Native iOS Kill Switch to block all traffic when VPN tunnel is dropped or unavailable

[NEW] Keep user settings on log out with an option to clear settings

[NEW] WireGuard diagnostic logs

[IMPROVED] Migrate to WireGuardKit framework

[IMPROVED] Upgrade WireGuard to the latest version

[FIXED] Current WiFi name not available, fixed for iOS 15.1+ devices

[FIXED] IPV4/IPV6 tabs displayed in connection info when there is no internet connection

Is there an ETA for Mullvad multi hop support via native Mullvad app (iOS, WIN, Android)?

as per title

IVPN for Android (v.2.8.0) is out with WireGuard Multi-hop

[New] Multi-Hop for WireGuard protocol
[New] Option to keep app settings on logout
[New] Server sorting by proximity
[Improved] Descriptions and UI overall
[Fixed] IVPN tile in the quick settings

https://www.ivpn.net/apps-android/
F-Droid in progress

Desktop and iOS releases with WireGuard Multi-hop are scheduled for early next week.

Bad Motherfucker Blues - The multi-genre playlist that consists of fight music, mostly Hip-Hop/Rapcore/Alternative/Nu-Metal. open.spotify.com/playlistโ€ฆ
"Explainable Multi-hop Verbal Reasoning Through Internal Monologue", Liang et al 2021 aclanthology.org/2021.naaโ€ฆ
'Love & Hip-Hop' Star Karlie Redd Signs Multi-Million Dollar Album Deal with Cryptocurrency based Label, Legacy Records prnewswire.com/news-releaโ€ฆ
What is a Multi-Hop VPN? blog.orchid.com/what-is-aโ€ฆ
Had to hop back on single player because I kept getting snaked on multi ๐Ÿ๐Ÿ˜‚ (realistic console gameplay๐ŸŽฎ) v.redd.it/twuvl5k7xtg71
Double Chain Wireguard (Multi Hop VPN)

Dear everyone,

I am trying to setup Double Chain Wireguard (Multi Hop VPN)

I want to connect to a VPS and on that VPS it connects to a VPN via wireguard.

I wonder what should I do to forward all traffic from client to VPN

I follow this topic but it doesn't work

https://www.reddit.com/r/WireGuard/comments/q10pti/my_wireguard_chain_working_fine_but_need_advice/

Surfshark Multi-Hop working on Netflix

Iโ€™ve been trying out various serverโ€™s with Surfshark to get back into Netflix and so far I have had no issues using the multi-hop servers rather than a single location. I know it for sure works for the UK โ€”> Germany server since I watched an entire movie on it. Iโ€™d be curious to hear if anyone else has had success with other Multi-hops!

Wireguard server multi-hop for some peers

I have several Wireguard servers hosted on Ubuntu VPS servers. There are peers setup on each VPN server. I have the servers setup in "mesh" configuration and they're all able to ping each other directly. The servers have ipv4 forwarding enabled. I can connect to each server as a peer and have my internet connection routed through that server.

I would like to forward some peers through multiple Wireguard servers (multi-hop) while also leaving some peers to connect to the internet via the first Wireguard hop. Eventually I intend to control this dynamically with a node app executing the relevant iptables rules as required (or whatever the solution may be)

For example:

Peer 1 > Server 1 > Server 2 > Internet

Peer 2 > Server 1 > Internet

Peer 3 > Server 3 > Internet

Peer 4 > Server 2 > Server 1 > Internet

https://i.stack.imgur.com/IJ7Y4.png

Would this be possible with iptables rules? I have spent a couple of days reading similar posts and trying things. The closest I have come is setting the following on Server1:

iptables -t nat -A PREROUTING -s 10.42.1.4(Peer1) -j DNAT --to-destination 10.42.1.2(Server2) 
iptables -t nat -D POSTROUTING -o wg0 -j MASQUERADE 

Using tcpdump -n -v -i wg0 I can see packets being passed from Server1 to Server2 but it looks like the MASQUERADE rule is altering the destination IP? I tried adding iptables -t nat -A POSTROUTING -d 10.42.1.2 -j SNAT --to-source 10.42.1.4
too but it appears to stop any traffic flowing from Server1 to Server2.

We voted "Yes" on Cosmos proposal #56! The proposal was to include a new feature to #IBC on the #Hub that allows for multi-hop packet routing for ICS20 transfers ๐Ÿ”ฅ
Wrote my first article on Medium.com, of course it should be about Vim. Wanted to emphasize that single-char, multi-line motion from Hop/EasyMotion is really efficient, precise, and works most of the time
Bad Motherfucker Blues - The multi-genre playlist that consists of fight music, mostly Hip-Hop/Rapcore/Alternative/Nu-Metal. open.spotify.com/playlistโ€ฆ
Need some help understanding eddbโ€™s multi trade routes and โ€œmax hop distanceโ€

I have a Type 7 that can currently hold 264 cargo, and max hop distance when full cargo is 16 ly, no cargo is 28 ly. When selecting max hop distance on eddb, do I do the full cargo distance range or no cargo distance range? Also, how accurate are the profits? Will I actually be making what the route says I will for โ€œtotal profitโ€? just havenโ€™t checked out the trade route stuff until now so Iโ€™m a bit confused.

Bad Motherfucker Blues - The multi-genre playlist that consists of fight music, mostly Hip-Hop/Rapcore/Alternative/Nu-Metal. open.spotify.com/playlistโ€ฆ
Another CoinSwap milestone: Multi-hop CoinSwaps. Undetectable bitcoin privacy is being built

Suppose Alice has bitcoins and wants to send them with maximal privacy, so she creates a special kind of transaction. For anyone looking at the blockchain her transaction appears completely normal with her coins seemingly going from bitcoin address A to address B. But in reality her coins end up in address Z which is entirely unconnected to either A or B.

Now imagine another user, Carol, who isn't too bothered by privacy and sends her bitcoin using a regular wallet. But because Carol's transaction looks exactly the same as Alice's, anybody analyzing the blockchain must now deal with the possibility that Carol's transaction actually sent her coins to a totally unconnected address. So Carol's privacy is improved even though she didn't change her behaviour, and perhaps had never even heard of this software.

In a world where advertisers, social media and other companies want to collect all of Alice's and Carol's data, such privacy improvement would be incredibly valuable. And also the doubt added to every transaction would greatly boost the fungibility of bitcoin and so make it a better form of money.

This undetectable privacy can be developed today by implementing CoinSwap. The software could be standalone as a kind of bitcoin mixing app, but it could also be a library that existing wallets can implement allowing their users to send Bitcoin transactions with much greater privacy.

For the last few months I've been working on implementing this project, and recently reached another milestone: Multi-hop CoinSwaps.

In the original CoinSwap design there would be only two peers involved, that meant if your wallet did a CoinSwap the other party knew exactly where your coins went. They were a single point of failure in privacy. Multi-hop CoinSwap is where the user routes their coins of multiple CoinSwap peers, and all of them need to collude in order to figure out the final source and destination of the coins.

Just for fun I created a 5-hop CoinSwap on testnet. Each hop has 3 individual transactions:

Taker's outgoing transactions:

https://blockstream.info/testnet/tx/f45349bd279bea20b8b218300f8e2416abf28f3858470ad8c5eb2f6cd5ec10a9

https://blockstream.info/testnet/tx/40ea5c9e478b66fa3f615c2b8d3accfd69308443d90a5353de669767cb02c51f

https://blockstream.info/testnet/tx/8fe245e9c433127af4df8ff8853650808e3281fed7de6bfda62066a3fd3ad36e

First maker funding transactions:

https://blockstream.info/testnet/tx/3d9b879866ad136f9fe6e80599e1b97d610b6330be3ab4aa7df4161fce

... keep reading on reddit โžก

Fall is only a day on the calendar. Almost 90f in the midwest. 8 hrs work, 6 mile bike ride( just starting)quenched by this very local multi hop brew with a hint of orange zest. Cheers my shower family!!
Mozilla VPN Boosts Security Through Custom DNS Server: How Multi-hop Feature Works? techtimes.com/articles/26โ€ฆ
Winners of the 2021 Brand of the Year Awards include Wonstein (Hip-Hop Musician), Heize (Female Vocalist), Nucksal (Male Multi-tainer) soompi.com/article/148443โ€ฆ
Good afternoon everyone, My name is Juhrel. I am a multi talented artist, I create my own graphics art and in most cases my own instrumentals and freestyles. This is more of a "modern" hip-hop song I just dropped called MEXICO. I hope y'all enjoy v.redd.it/15bgrm94o3n71
What happens in a multi-hop transaction if an intermediary closes their channel?

My understanding of lightning is pretty basic, so bear with me.

Lets say Alice wants to open a channel with Carol but they don't have a channel open yet. They both already have a channel open with Bob, so they route it through Bob to minimize fees. Is it possible for Bob to close his channel with Alice or Carol while Alice and Carol have not settled with each other yet? If so, what happens to Alice and Carol's payments to each other?

And does this behave any differently as you scale up the network and have more hops between Alice and Carol?

Bad Motherfucker Blues - The multi-genre playlist that consists of fight music, mostly Hip-Hop/Rapcore/Alternative/Nu-Metal. open.spotify.com/playlistโ€ฆ
ProtonVpn Secure Core vs IVPN Multi-Hop

Is IVPN multi-hop equivalent to the ProtonVPN Secure Core?

In both cases, data flows through 2 servers.From Protons website (link):

  • "Secure Core servers are wholly owned and provisioned by us (shipped on-site directly from our offices)"
  • "Secure Core servers are connected to the Internet using our own dedicated network with IP addresses that are owned and operated by our own Local Internet Registry (LIR)."

Does the second point imply that network monitoring would be difficult on those servers?

For IVPN, I think all the servers are rented.

I would like to objectively understand which one (ProtonVpn Secure core vs IVPN multi-hop) will be more secure and private.

(i.e. are the above 2 points made by Proton just marketing or they do indeed make the service more secure/private)

The Hillsboro Hops are preparing to implement a $40M-plus stadium expansion โ€” most of it privately funded โ€” that will transform The Tonk into a multi-use venue (Portland Business Journal)

https://www.bizjournals.com/portland/news/2022/01/19/hops-bids.html?ana=TRUEANTHEMTWT_PO&csrc=6398&taid=61e851aef89f730001e56f2b&utm_campaign=trueAnthem%3A%20Trending%20Content&utm_medium=trueAnthem&utm_source=twitter&s=09

Can't get multi-hop static route to work. Trying to reach 192.168.100.0 network through a VPN router connected to an intermediate router

Starlink > Netgear router > DD-WRT VPN Router

I have a static route from my Netgear router (10.0.0.1) that allows me to view Starlink statistics on 192.168.10.1 through the WAN port

The WAN port on my VPN router (10.10.20.1) is connected to a LAN port on my Netgear router. I set a static route to 10.0.0.0 on the VPN router and I can ping 10.0.0.1 and access the GUI.

To access 192.168.100.1, I set a static route on the VPN router:

I was thinking that a static route to the Netgear would pass my request for 192.168.100.1 througn the static route I had set up in the Netgear router, but it doesn't. What am I missing?

Please note that this site uses cookies to personalise content and adverts, to provide social media features, and to analyse web traffic. Click here for more information.